Note d'information à lire avant de télécharger ou d'utiliser les logiciels. 
Les logiciels de Plongeur++ : utilisent des bases de données brutes sensibles issues directement du module "Base" de libreOffice si vous n'êtes pas familiarisés avec celles-ci, il est fortement conseillé de télécharger le document ci-contre "Utilisation de base de données brutes" ainsi que les divers tutoriels sur leurs fonctionnement et utilisation. 
J
e teste pour vous toutes les versions de LibreOffice et de Java.

Si vous utilisez d'anciennes versions de logiciel de Plongeur++ et une versions de LibreOffice supérieur à la 6.1, il est impératif de mettre à jour vos logiciels compte tenue des modifications importantes de cette suite concernant le module Base.

LibreOffice : Versions utilisables (voir ici) pour les logiciels de Plongeur++ utilisant Base avec le sgbd HSQLBD.
Version LibreOffice 7.1.7.2 et sup. Logiciels utilisants HSQLBD = Tous 
Version LibreOffice 6.0.7.3 et inférieur. Logiciels utilisants HSQLBD = tous sauf Membres
Version LibreOffice 6.1 et supérieur. Logiciels utilisants HSQLBD = Qrcode, Carnet, Plongeurs,  Patrimoine, Participants TIV-L et TIV.
Version LibreOffice 6.1 et supérieur. Logiciels utilisants FIREBIRD : le développement de ces logiciels est arrêté compte tenu de l'absence d'équivalence de nombreeuses fonctions par rapport au HSQLBD

Attention
Ne pas activer les fonctions expérimentales dans les options de L.O, elles activent le moteur sql 'Firebird' à la place de 'HSQLDB'. Voir la note de version de LO 6.1 ici.
Utiliser la version 6.2.5.2 et sup 'expérimental' remplace d'office le SQL 'HSQLDB' par 'FIREBIRD' pour toutes nouvelles base créées'. Les logiciels deviennent incompatibles avec le SQL 'HSQLDB'! Voir la note de version LO 6.2 ici. Vous pouvez toutefois pour l'instant continuer d' utiliser une ancienne base existante HSQLDB sous L.O. 6.2 et supérieur, sauf que celle-ci ne restitue pas les images dans les boutons (bogue de LO version 6.1). Les nouvelles versions de Plongeur++ utilisant HSQLDB sont maintenant adaptés à ces bogues voir ci-dessus. Il est est donc conseillé de migrer vers une nouvelle version.

De nouvelles versions des logiciels de Plongeur++ adaptés à la version 6.2 et supérieur de LibreOffice ont été réalisées. Ils utilisent le nouveau module Base avec le sgdb HSQLDB (tous les logiciels), pour le sgdb FIREBIRD voir ici.
Firebird : vous cherchez des informations sur Firebird Cliquez ici
Versions de LibreOffice : historique des versions LibreOffice:
Utilisez uniquement des versions  "Stables", pas de version dite "Evolution" par définition instable! Dernière version stable voir ici.
Version 7.1.6.2 ne pose pas de problème
Version 7.0.6.2 ne pose pas de problème. A noter la rétro-compatibilité n'est pas assuré avec le module base, notamment pour certains Formulaires et surtout les Rapports.
Version 6.4.7.2 ne pose pas de problème
Version 6.4.6.2 génére toujours un bogue avec des variables dans les macros des logiciels, une mise à jour de ceux-ci est en cours.
Version 6.4.5.2 génére un bogue avec des variables dans les macros des logiciels, une mise à jour de ceux-ci est en cours.
Version 6.3.6.2 ne pose pas de probléme particulier. Notez toutefois que les fenêtres des documents Base ne comportent plus de partie blanche périmétrique.
les versions 6.1 et 6.2 comporte des bogues d'affichage des images  dans les boutons et les boutons pictos. Plongeur++ à compensé les erreurs.
La version 6.2.8.2 ne pose pas de problème.
La version 6.0.7.3 ne pose pas de problème.
ATTENTION : Version 5.4.4  de L.O. est remplacée par 5.4.5 voir ici
Les versions 5.2.x.x et 5.3.x.x ne présentent pas de probléme détecté, sauf pour certaines versions des erreurs de visualisation dans les fichiers Calc ouverts depuis le module base. Les versions 5.4.x.x ne posent pas de problème particulier.
La version stable 5.1.6.2
 présente un problème de gestion des boutons composites (Image & texte). Pour pallier à cette modifiaction du module base de Libreoffice, il est nécessaire de migrer les logiciels de Plongeur++. Les versions dont la date de mise en tétéchargement est supérieure au 09/01/2017 sont adaptées à cette modification. 
Ne pas utiliser de version de LibreOffice inférieure à 4.1.3.2 pour ces logiciels et mises à jour. 

Concernant JAVA : utiliser JAVA en 32 ou 64 bits suivant votre configuration, pour Windows  8 et 10 (actuellement jre 8u311).
IMPORTANT: vérifier dans le menu de LibreOffice Outils/Options/Avancé la présence de Java activé.

Les fichiers à télécharger : sont soit des Setup.exe, soit des zip à décompresser ou des PDF. Le setup d'installation vous donne les instructions nécessaires pour une bonne utilisation du logiciel. L'éxécutable est un fichier ODB, les informations nécessaires à son lancement et à son emplacement sont également indiquées dans le fichier "Pour démarrer avec (nom du logiciel).html". Ce fichier html s'ouvrira dans votre explorateur internet.

Sécurité : ces logiciels sont téléchargeables uniquement sur ce site. Si vous les trouvez sur un autre site, ils ne sont pas autorisés et leur contenu peut être douteux.  Cas des Setup.exe :en l'absence de signature numérique reconnue par Microsoft ® qui peut générer une alerte ( voir le tuto "Pourquoi") vu son absence et non un fichier corrompu, vous pouvez vérifier leur authenticité  au moment du téléchargement, en comparant la somme de contrôle original  (checksum) visible pour chacun d'eux. Toutes les macros contenues dans les logiciels sont accessibles et leurs codes visibles en clair.
Pour savoir comment utiliser les "checksums" voir ici.

Firebird

Si vous êtes désireux d'en savoir plus sur Firebird voici plusieurs liens  utiles :

Le site offficiel de Firebird
Suivre l'actualité de Firebird
Migrer de HSQLDB vers Firebird
Des supports pour développer avec Firebird
Une FAQ Firebird
Le Wiki de LibreOffice concernant le module base et Firebird
La FAQ de Firebird
Des exemples pour Firebird
Un PDF sur Firebird expliqué ( le document date mais il est toujours d'actualité


Copyright  © 2017 - 2021
Michel Dumont  
tous droits réservés